Redmine auf aktuellen Stand gebracht, so ist es abgelaufen

Es braucht gar nicht weiter gelesen werden. Ich habe die Aktion abgebrochen. Ich habe eigentlich jede Hürde gemeistert. Ruby in korrekter Version, Rails und Passenger. Passenger ohne Fehlermeldungen. Mysql2 und weitere Dinge, alles hinbekommen. Keine Fehlermeldungen. Aber es funktioniert dennoch nicht. Auch /public ist korrekt.  Redmine will einfach nicht starten. Nachdem ich derart viel Zeit mit dem Thema verbracht habe, musste ich mir wieder ehrlich gestehen, dass man sowas nicht „mal eben“ macht und man sich mehr als gedacht in die Sache rein hängen muss.

Sollte ich sowas noch einmal in Angriff nehmen, denke ich daran schon mal viel Zeit zu reservieren. Und: Ruby On Rails ist nicht meine Welt.


 

Welche Umgebung liegt vor?

Welche Linux-Version?

zulu1902:~# uname -a
Linux zulu1902.*******.de 2.6.32-5-amd64 #1 SMP Tue May13 16:34:35 UTC 2014 x86_64 GNU/Linux

Welche Distribution?

zulu1902:~# lsb_release -a No 
LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 6.0.10 (squeeze)
Release: 6.0.10
Codename: squeeze

Welche Ruby-Version ist installiert?

zulu1902:~# ruby -v
ruby 1.8.7 (2010-08-16 patchlevel 302) [x86_64-linux]

Welche Rails-Version ist installiert?

zulu1902:~# rails -v
Rails 2.3.5

 Welche Umgebung ist erforderlich?

ruby 1.9.33, 2.0.02, 2.1, 2.2.1
Rails 4.20

Demnach muss Ruby wie auch Rails zunächst aktualisiert werden. Ich habe es zunächst mit RVM probiert, aber irgendwie ursächlich fieser Fehlermeldungen im Zusammenhang mit MySQL den Faden verloren. Nichts ging mehr. extconf.rb:67:in `<main>‘: uninitialized constant Config (NameError) ist zwar relativ sprechend, auch habe ich erfahren, es es nicht mehr Config sondern RbConfig ist. Aber ist habe die Probleme nicht lösen können. Ein beherztes

rvm implode 

hat dieser Geschichte, deren Sinn ich im Nachhinein gar nicht mehr nachvollziehen kann, ein entsprechendes Ende gesetzt. 

 

1. Update Ruby On Rails

Ich habe Ruby zunächst vom System entfernt. Mit
sudo apt-get remove ruby1.8
war das schnell erledigt. Dann habe ich nach dieser Anleitung Ruby komplett neu eingerichtet. Mit
wget ftp://ftp.ruby-lang.org/pub/ruby/2.3/ruby-2.3.0.tar.gz
heruntergeladen und mit folgenden Kommandos kompiliert und installiert:

cd ruby-1.9.3-p547
./configure --enable-pthread --prefix=/usr/local 
make && checkinstall --type=debian --install=yes --fstrans=no --pakdir='~'

Ein erneuter Versuch… 

Ich laufe noch immer auf viele Fehler, also versuche ich es erneut:

rvm install 2.2.1
rvm use 2.2.1
rvm install rails

Probleme mit Passenger

Leider gibt es erhebliche Probleme bei der Installation des Passenger Application Servers. /mod_passenger.so ist nicht zu finden. Ein beherztes

find -iname mod_passenger.so 

hat mir dann den wahren Ort den Apache-Moduls verraten und ich konnte, abweichend von der Installationsdokumentation, den korrekt Pfad eintragen. Und siehe da, Webserver Apache läuft wieder. Nun mit geladenem Passenger-Modul.

Nun kann das Update Redmine durchgeführt werden

Die Anleitung hierzu habe ich hier gefunden: http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade

1. Backup

Da sowieso jeden Tag ein Backup durchgeführt wird, beschränke ich mich auf die Kontrolle, ob es denn heute auch funktioniert hat. Wobei nur die Datenbank gesichert und auf einen anderen FTP-Server übertragen wird, jedoch nicht die Dateien. Dies mache ich sicherheitshalber auch fix per WinSCP manuell. Zu finden in /usr/share/redmine/files

2. Das Update

Es gibt 2 Varianten: Download des Stable Releases oder Checkout aus einen SVN -Repository. Da Letzteres sehr einfach erscheint, es sind nun 2 Befehle an der Kommandozeile, versuche ich zunächst die 2. Option.

svn update
bundle update

Ein schönes GitHub-Markdown-Feature für Tabellen

Man kann auch die Spaltenbreite in Tabellen bestimmen. Die Anzahl der Bindestriche bestimmt dies. Demnach ist es nicht beliebig, wieviele Bindestriche man in der zweiten Definitionszeile einträgt. Drei sind es mindestens, aber mehr als drei erweitern die Spaltenbreite.

Das

|Nummer|Beschreibung-----------|Ort------------|Menge|Preis|Summe|
|------|-----------------------|---------------|-----|-----|-----|

ist nicht gleich das:

|Nummer|Beschreibung-----------|Ort------------|Menge|Preis|Summe|
|---|---|---|---|---|---|

 

 

 

Kündigungen sind bei Unitymedia offensichtlich Bestellungen

Das muss man nicht verstehen, oder? Ich kündige bei Unitymedia und bekomme eine Auftragsbestäting. Ok, den Auftrag eine Kündigung durchzuführen, kann ich ja noch verstehen. Aber dann kommen E-Mails mit dem Inhalt „Ihre Bestellung“. Und wenn ich mir den Status auf der Website an sehe, werde ich misstrauisch. Also schnell mal eben angerufen. Schnell mal eben den Eindruck abgeholt, dass man als Kunde für relativ dämlich gehalten wird. Das Wort „Kündigung“ kommt in keiner Mail auch auch nicht im Account vor. Aber wie würdet ihr diesen Text werten:

Lieber Unitymedia Kunde,

Sie kamen uns gleich so bekannt vor…
Anhand der bei Ihrer Bestellung angegebenen E-Mail-Adresse haben wir festgestellt, dass Sie bereits einen Kundencenter-Account bei uns haben.

Die Vorteile Ihres persönlichen Kundenbereichs sehen Sie auf einen Blick oben in dieser E-Mail.
Loggen Sie sich doch gleich ein und verfolgen Sie z. B. den Status Ihrer aktuellen Bestellung.

https://app.unitymedia.de/kundencenter/?cid=nosid_UES

Herzliche Grüße
Ihr Unitymedia Team

Oder diese Einträge im Account:

unitymedia